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Spartan Dairy 3 
• If you find a bug, please report it to us.  You can either send to mikevh@msu.edu with 

Spartan Dairy bug in the subject line or make a comment in the discussion forum on the 
ANGEL site.   

 
Tips for using Spartan 3 
• If something quits working while using the program, save the file as a new name.  Then 

exit the file and try opening it again.  If that does not work, exit the program, and then 
get back into it and open the file.   

• Evaluating nutritional adequacy.  Whether a diet already being fed or starting from scratch, 
the nutrient balance graph can help.  Turn it on or customize it with Settings in the menu.  
When formulating a new diet, it is especially helpful to change settings so you can see ForNDF 
(forage NDF).  The graph should have DMI, NDF, EfNDF, ForNDF, NEL, CP, RDP, MP, Ca, P, 
Na, Se, and Vit A.  To formulate the diet, work your way down the graph.   

• Editing Feed Characteristics.  If you have a new feed to put in the Spartan 3 library or a 
ration, first find a feed that is similar.  Then select the feed and use Feeds > Nutrient 
Composition and, at the minimum, edit %DM, %NDF, and %CP.   
• If you have information, edit %ash, %EE, %Ca, and %P.   
• If you have information on lignin you can enter it.  If lignin is much different than the original 

value, you should edit NDF digestibility.  See help on this.  Higher lignin means lower 
digestibility, which will decrease energy value.   

• Energy values are calculated in Spartan 3, so they will change as you alter other nutrients.   
• If this was a new feed test, change the TestDate.   
• If you know more mineral information, change that too.   
• RUP and RDP are calculated fields in Spartan 3.  To adjust them, you must change the B 

and C protein fractions.  It is best to do this in the protein tab, so you can see the resulting 
values for RUP and RDP as you change them.   

• NFC is a calculated field in Spartan 3.  If you have NFC or NSC , and the value in Spartan 
is not close, you can adjust it by editing either ash or EE.   

• For commercial feeds, you might want to make an equal mix of the first 3 ingredients, copy 
it to be a real feed, and then edit as needed.  Remember that nutrient content on a feed tag 
is on an amount AsFed basis, but Spartan has nutrients on a DM basis (except Cost 
AsSold).   

• Alfalfa haylage is the same as legume silage. 
• Target animal.  For most early lactating cows, set TARGET MILK to match the average milk 

actuall produced.  ACTUAL MILK does not impact requirements but is used as a monitor, and 
is especially useful if you lead feed a group—feed for more milk than the average.  . 

• Working in the worksheet.  When you balance a diet, work mostly in the Home tab.  The 
order of columns within the home tab can be rearranged.  Just click on a heading and drag it.  
Unfortunately, sometime when you do this, the columns order in the feeds sections can 
become out of sync with the columns of the ration summary.  If his happens, either save the file 
and reopen or use the Settings > Column Order menu command.  To move columns and 
ensure proper synchronization, move to either about the 12th or later place or to the first place 
(right after Amount DM).  A good order is: %diet, NDF, EfNDF, NEL, CP, RUP dig, FA, Ca, P, 
Se, CostDM, AsFed, and DM%.  If you move these to the first column using the reverse order, 
it will work perfectly.  You also should consider sorting feeds according to feed type.  Either 
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click the Feed Type heading once in the Misc tab or use the Feeds > Sort Feeds By 
command. 

• Formulating a diet.  When you balance a diet, adjust feeds on a DM basis or percent of diet 
basis.  Work your way down the nutrient balance graph. 

a. add forages to meet the ForNDF requirement on fiber tab,  
b. adjust concentrates until 98% of the predicted DMI is met.  Adjust forages and 

concentrates to meet energy and fiber requirements.    
c. replace some of the concentrates with protein supplements to meet CP reqt. 
d. replace some of the CP supplementw with MP supplements if necessary 
e. recheck to make sure NDF, EfNDF, ForNDF, NEL, CP, and MP are reasonable 
f. add salt at ~.25-0.5% of DMI and limestone and/or dical to meet Ca and P 
g. add a trace mineral and vitamin supplement .  

• Printing.  When you Print, only one file can be open.  If more than one file is open, the 
program always prints the first one that was opened.To PRINT, go the Reports – Summary 
Report and input your name in the prepared by spot.  Then hit the print button on right side.  
Then choose preview.  If everything looks okay, press Print.     

• Computer vs cow.  As with any computer program, the cow should be the judge of nutritional 
adequacy.  Evaluate the actual response to a diet change by monitoring DMI, estimate energy 
intake, and milk production and then fine tune the diet accordingly.  Body condition is helpful 
too but takes longer to evaluate.  The DM content of wet feeds should be checked regularly. 
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Tutorial 
Creating a Ration for Scratch 
 
In this exercise, we will formulate a diet using defined feeds and determine if it would be cost-
effective to use cottonseed in the diet.   
 
The target animal will be a Holstein cow in early lactation.  She is 2nd lactation, has a mature BW 
of 700 kg and a current total BW of 600 kg with a body condition of 2.5.  She is at 60 days after 
calving and is producing 110 lb of milk at 3.5% fat and 3.2% protein.   
 
The feeds to use in this example are in the following table.  We will use library values for any 
feed characteristics that are not known.  We will use feed test results for the mixed alfalfa/grass 
silage.   

 
Corn silage   
   34% DM, 41% NDF, 7.0% CP 

$41  
/ton 

Alfalfa grass mixed silage 
   Specs are in lab report 

$46 
/ton  

Cottonseed   $225 
 /ton 

Corn grain, ground   
    9.5%CP 

$4.10  
 /bushel 

Canola meal $280   
  /ton 

Hydrolyzed tallow fatty acids $45  
 /100 lb 

Soybean meal-48 $340  
  /ton 

Expeller soybean meal $388  
  /ton 

Limestone $7.50  
  /100 lb 

MSU MinVit premix 
98% DM, 8.6% Ca,  8.2% P,   
7.5% Mg,  0.6% K,  13% Na,   
20% Cl,   2.8% S,  600 ppm Cu,  
4000 ppm Fe,  2500 ppm Mn,   
2500 ppm Zn,  7 ppm Co,  40 ppm I,  
20 ppm Se,   120 kIU vit A/lb,   
30 kIU vit D/lb,  1200 IU vit E/lb 

$31  
  /100 lb     

 
Whenever you make a new feed in Spartan 3, always use an existing similar feed as the template.  
Although Spartan 3 has about 120 feed characteristics, only about 10 need editing from a feed test 
report.  The easiest way to do this is with Edit Nutrient Composition dialog under Feeds in the 
worksheet menu.   

SAMPLE DESCRIPTION: Mixed Silage     ID #331585 

WET CHEMISTRY ANALYSIS RESULTS 
 
COMPONENTS AS SAMPLED  DM 
 BASIS BASIS 
% MOISTURE 67 ******* 
% DRY MATTER 33 ******* 
% CRUDE PROTEIN 6.5 19.6 
% AVAILABLE PROTEIN 6.0 18.1 
% UNAVAILABLE PROTEIN 0.5 1.5 
% ACID DETERGENT FIBER 10.8 32.4 
% NEUTRAL DETERGENT FIBER 15.0 45.1 
% NSC 7.6 22.7 
% TDN 16 58 
NEL, (MCAL/LB) 0.17 0.60 
NEM, (MCAL/LB) 0.16 0.58 
NEG, (MCAL/LB) 0.09 0.32 
% CALCIUM 0.33 1.01 
% PHOSPHORUS 0.10 0.30 
% MAGNESIUM 0.07 0.24 
%POTASSIUM 0.95 2.85 
% SODIUM 0.008 0.024 
PPM IRON 75 225 
PPM ZINC 10 30 
PPM COPPER 4 11 
PPM MANGANESE 12 37 
PPM MOLYBDENUM 0.8 2.3 
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1. Setting up the ration.   

Choose new ration and select Holstein lactating cow.   

 

 

 

 

 

Describe the target cow.  Enter information given 
on the previous page for this cow.  In the Describe 
the Target Cow dialog, choose early lactation and 
lactation number 2.  The program should 
automatically list 60 days in milk.  Then enter a 
mature BW of 700 kg and a current total BW of 600 
kg.  If the information is listed in pounds instead of 
kg, you can enter 1540 lb for mature weight and 
1320 lb for current weight.  Currently if you change 
mature BW, current total BW may be altered.  If it 
is wrong, just edit it again.   

Next enter 50 kg (or 110 lb) of milk at 3.5% fat and 
3.2% protein.  The dialog should look like this if 
you are in metric basis.   

 

The last step in describing the cow is the Set 
Daily Body Weight Gain Parameters 
dialog.  Note that when you change the 
current body condition score to 2.5, the 
current nonpregnant body condition 3 (BC3)-
adjusted BW stays the same and the total BW 
is altered.  Go ahead and change it back to 
600 kg (1320 lb).  The target BC3 BW is the 
mature wt—just leave it there.  Put the target  
BCS at 3.5 in 240 days.  This will result in a 
target frame gain of 0.20 kg/d and a BC gain 
of 0.19 kg/d for a total gain of 0.39 kg/day or 
0.86 lb/day.   
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Choose feeds.  Next the program opens the dialog in which you choose a library for selecting feeds.  
You can choose any library or ration file for this, but we 
will choose the Master feed library.   

The Add Feeds dialog opens and you can select the 
feeds that were mentioned at the beginning of this 
exercise.  The left bottom panel of this dialog shows the 
feeds in the source file (Master Feed Library in this case) 
that match the criteria in the top panel of the dialog.  In 
this example, the only feeds shown are those that have 
the word “soy” in the feed name field.  Note that as you 
try to find feeds that match your descriptions, you can 
expand the left side of the dialog so that you can see the 
test date, %DM, %CP, and %NDF of the library feeds.   
When you find a feed you want, simply double click it or 
click it once and press 
Add Selected.    

For our exercise, the 
“legume silage w  
grass, mid mature” 
seemed closest to our 
tested mixed silage and 
the 1.5% MinVit mix 
seemed a reasonable 
template for our minvit 
premix.  After the 
feeds have all been 
selected, press   

Sort feeds.   Choose 
Feeds>Sort Feeds 
By>Feed type and name to arrange the 
feeds in an organized fashion.  This will 
make balancing the diet more methodical 
and easier.   
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Adjust feed characteristics to 
match actual feeds on farm 

First we will edit feed names, % DM, 
and costs for our feeds.  Just type 
over existing fields to edit them.   

Then highlight MSU MinVit mix row 
and select Feeds>Nutrient 
Composition or press Ctrl+P to pull 
up the Edit Nutrient Composition dialog.  Edit the values for minerals and vitamins according the 
specifications given at the beginning of this exercise.   

Now do the same for the mixed alfalfa grass silage.  Only adjust values for which new information 
is known.  Calculated fields, such as NEL, are not shown in this dialog.   
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Check feed characteristics 

Fiber tab. 

We will use the default values 
for NDF effectiveness and NDF 
digestibility.  NDF digestibility 
is a major determinant of the 
energy value of high fiber feeds.  
If lignin was in the forage test, 
we could have used help in Feed 
Characteristics: Fiber to edit 
NDF digestibility. 

Protein tab 

This is just a quick check 
to make sure the RUP and 
RPD values of our feeds 
seem reasonable.  These 
are calculated from the A, 
B, and C fractions and 
KdB of a feed. See help on 
Feed Characteristics: 
Protein.   

Carbohydrate tab 

This is just quick check to 
see if NFC seems 
reasonable.  It is a 
calculated value and will likely change 
anytime other nutrients are edited. 

Energy tab 

Go to the energy tab to see the new 
calculated values for energy of the silage or 
other feeds.  Switch between “kg” and “lb” 
basis to get the value you want.   

 

Modify the Nutrient Balance Graph 

Choose Settings>Nutrient Balance Graph from the 
menu or right-click on the graph and then edit the 
selection of nutrients displayed on the graph.  In this 
example, we added Forage NDF, NRC 2001 NEL, 
and NRC 2001 MP.   
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2. Balancing the ration 

We will now work our way down the list of feeds and down the nutrient balance graph to 
systematically balance the diet.  Here is what the ation worksheet looks like in pounds to start off. 

      
Balance for fiber and energy.   

First add forage to make up 
about half of the diet until we 
meet the requirement for 
Forage NDF.  We start with 8 
lb alfalfa/grass silage and find 
it takes 18 lb corn silage to 
meet ForNDF requirement.  
We are short on total NDF and 
EfNDF, but the other feeds we 
add do have some of these.   

Add the MSU MinVit mix at 1.5% using the %Diet column (it was designed to be fed at this rate). 

Add corn grain to get close to the predicted DM intake of 57 lb.  In the end, we will not be feeding 
this much corn because we will need some protein supplement, but this gives us an idea of how the 
balance of 
fiber and 
energy will 
look.  We are  
short on 
energy but 
that may 
happen with a 
very high 
producing 
cow at 60 
DIM.  We can 
move on.   
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Balance for protein by altering the concentrate portion of the ration.   

First add the regular 
SBM until the CP 
and MP supplies are 
close to meeting 
requirements.   

Note that after 
adding the soy, the 
fiber supply looks 
good.   

The diet is a little 
short on MP, so we 
will try some 
expeller SBM (high 
in RUP).  We take 
out 5 lb of Soy-48 and add in 5 lb expeller SBM.  The protein now looks pretty good.  The CP is a 
little short, but that is fine because MP is more important.  The MP system depends on more 
calculations, however, so we would want the CP to be somewhat close to requirements.  In this 
case, we are only 5-6% short on CP, so it’s okay.  RDP supply is good.   

Now go to the Mineral tab and add limestone until you meet Ca requirement.  In this case, we are 
2% short on total Ca, but we have plenty of absorbed Ca.  The other minerals all are okay, although 
Na is 10% short.  We will ignore this, although it might be worth supplementing more Na.   
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We are now ready to check over the diet and reassess our fiber, energy, and protein work in light of 
the total DM supply relative to requirements.  We actually have a little more EfNDF and ForNDF 
than needed, and we are about a half pound over on feed DM.  So we will drop the legume silage to 
7.5 lb.  It is not necessary to be so close on feed DM (being within 1% of the requirement is 
perfectly fine), but in our case, we wanted to minimize the fiber in the diet (while still supply 
enough to keep the rumen healthy) so that we could maximize the amount of feed and energy the 
cows would consume.  We are ready for our final checks.   

Check the Trace mineral tab.  In this case, some such as Cu and Zn are a little short, but note that 
we did not give most of our feeds any credit for trace minerals.  Given that our MinVit mix is 
supplying well above 50% of the requirement, this calculated shortage is not a concern.  

 

Check the Vitamin tab.  In this case, all three vitamins 
are short, but again we did not give most of our feeds 
any credit for vitamins.  Given that our MinVit mix is 
supplying about 40% of the requirement, this calculated 
shortage is not a concern.  
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Check the Ratios and 
Relationships dialog.  Select 
Ration>Ratios and 
Relationships, press Ctrl+R, or 
press the  button.    

Note energy-allowable milk is 
less than the target of 110 lb but 
protein-allowable milk is close.  
Unless the cow eats more than 
predicted, or the energy value of 
our feeds is greater than 
predicted, this cow will likely 
lose some body condition and/or 
produce less than expected.  Note that income over feed costs is negative –this is because we did 
not enter a milk price in the cow description.  Press okay.   

Check the home tab  again and note the cost of the ration---$5.63 per day. 

 

 

3.  Save the file. 

After creating the ration, you should save it.  
In this example, the ration is for a group of 
cows at the MSU Dairy, so I save the file in a 
folder called MSU Dairy.  Choose File>Save 
as... and save as with any other windows 
program.   
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4. Consider feed options 

Currently Spartan 3 does not have an optimizer cost evaluator.  (its completely designed but not 
coded).  But we can easily check the impact on nutrients and ration cost of other available feeds.  
Let’s first check the impact of adding 2% Hydrolyzed Tallow Fatty Acids in place of corn.  Type 2 
into the %Diet column for HTFA, and subtract 1.14 lb from corn grain. 

  

Note this increased NEL intake by almost 2 Mcal and energy-
allowable milk by ~6 lb (press  button).  This costs 40 cents 
more per day; however, we are assuming the cow will eat the same 
amount!  If she drops her intake 1-2%, we will not have gained 
anything.   
 
 

 

Now let’s see what would happen to nutrient specs and to ration 
cost if we added 5 lb of cottonseeds.  We must also subtract 5 lb of something.  Because 
cottonseeds is high in NDF but we consider it to be only 50% effective, we will drop forage 2.5 lb.  
The other 2.5 lb will be subtracted from corn.  So now we have 5 lb mixed silage, 5 lb cottonseeds, 
and 17.5 lb corn grain.  Note this increased NEL intake by only 0.6 Mcal (2 lb of milk) and 
increased ration cost by 24 cents /day.  However, we are assuming the cow will eat the same 
amount!  If the intake drops, this was an expensive mistake.  If the intake increases, it might be 
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worth it.   

5. Print reports.  

First print the summary 
report.  Choose 
Reports>Summary Report 
from the menu.  In the 
settings dialog, you can 
enter your name, give the 
diet a name, and enter the 
farm name.  Check the box 
for alternating row colors.   

Press the  button.   

 

In the first output options dialog, select preview.   

The summary report is usually 2 or 3 pages.   

 

 

 

 

 

If you are happy with the report, 
choose File>Print or press the   
button.   

 

The second Output Options dialog 
will appear.  In this dialog, you may 
choose to print only page 1 or pages 
1 and 2.  Sometimes page 3 has no 
useful information and you may 
want to save the paper.  
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Next print the batch report to use the recipe for mixing a ration.  Choose Reports>Batch Reports.  
In addition to the general settings you set for the summary report, you now can edit setting for  
batch size and mixing order and type notes.         

 

 

 

 

 

 

 

 

 

 

The first page of the batch report 
looks like this.  Click  to print.   

 
This concludes the tutorial on formulating a new lactation diet.   I apologize if you use kg instead of 
pounds.  I hope you could follow it anyway.   


